Ubuntu-Linux Users

From SpaceElevatorWiki.com
Revision as of 06:33, 19 March 2009 by Keithcu (Talk | contribs)

Jump to: navigation, search

Page in progress

Contents

OIS

sudo aptitude install libois1 libois-dev 

Ogre3D from source

OgreDotNet complains if you do not have the NVidia Cg Toolkit Ogre plugin installed. It's not compiled in within ubuntu's ogre distribution, that is why we need to install Ogre3D from sources.

Dependencies :

sudo aptitude install libzzip-dev libzzip-0-13 libxaw-headers libxmu-dev \
libxmu-headers libxpm-dev libfreeimage-dev libfreeimage3 libxrandr nvidia-cg-toolkit \
libfreetype6-dev libxaw7-dev libxxf86vm-dev libxrandr-dev xlibmesa-glu liblu1-mesa-dev

Get:

wget http://downloads.sourceforge.net/ogre/ogre-v1-4-9.tar.bz2

Build:

./configure --prefix=/usr --enable-openexr && make && sudo make install

OgreDotNet

sudo aptitude install swig cmake nant libmono-winforms2.0-cil
svn checkout http://ogredotnet.googlecode.com/svn/trunk/ ogredotnet-read-only 
cd ogredotnet-read-only
bash ./build.sh

MyGUI

sudo aptitude install uuid-dev uuid libfreetype6-dev libfreetype6
svn co https://my-gui.svn.sourceforge.net/svnroot/my-gui/trunk my-gui  
cd my-gui
sh bootstrap
./configure --prefix=/usr
make
sudo make install
Personal tools