Difference between revisions of "Ubuntu-Linux Users"

From SpaceElevatorWiki.com
Jump to: navigation, search
(OgreDotNet)
(OpenAL)
 
(10 intermediate revisions by 2 users not shown)
Line 1: Line 1:
''Page in progress''
+
== MonoDevelop ==
 +
Ubuntu 9.04 has Mono 2.0 and MonoDevelop 2.0 beta. All the pieces are now in the repository!
 +
sudo apt-get install monodevelop-debugger-mdb monodevelop-debugger-gdb
  
 
== OIS ==
 
== OIS ==
 +
Get OIS 1.2 from sourceforge:
  
  sudo aptitude install libois1 libois-dev
+
sh bootstrap
 +
./configure --prefix=/usr
 +
make
 +
  sudo make install
  
 
== Ogre3D from source ==
 
== Ogre3D from source ==
 
 
OgreDotNet complains if you do not have the NVidia Cg Toolkit Ogre plugin installed. It's not compiled in within ubuntu's ogre distribution, that is why we need to install Ogre3D from sources.
 
OgreDotNet complains if you do not have the NVidia Cg Toolkit Ogre plugin installed. It's not compiled in within ubuntu's ogre distribution, that is why we need to install Ogre3D from sources.
  
Line 19: Line 24:
  
 
== OgreDotNet ==
 
== OgreDotNet ==
 
 
  sudo aptitude install swig cmake nant libmono-winforms2.0-cil
 
  sudo aptitude install swig cmake nant libmono-winforms2.0-cil
  
Line 25: Line 29:
 
  cd ogredotnet-read-only
 
  cd ogredotnet-read-only
 
  ./build.sh
 
  ./build.sh
 +
 +
=== Issue ===
 +
 +
Under some circumstances, prebuild complains because the root Xml node of the prebuild.xml file should be called "PreBuild" instead of "Prebuild" (notice the subtle uppercase B). Try both in case of doubt.
  
 
== MyGUI ==
 
== MyGUI ==
 +
sudo aptitude install uuid-dev uuid libfreetype6-dev libfreetype6
 +
bzr branch lp:~jeko-ios-software/openracing/mygui-or
 +
cd mygui-or
 +
./configure --with-ogredotnet=../ogredotnet-read-only/bin
 +
make
 +
sudo make install
  
sudo aptitude install uuid-dev uuid libfreetype6-dev libfreetype6
+
'''Below is not used yet:'''
 +
<strike>
 
  svn co https://my-gui.svn.sourceforge.net/svnroot/my-gui/trunk my-gui   
 
  svn co https://my-gui.svn.sourceforge.net/svnroot/my-gui/trunk my-gui   
  
Line 36: Line 51:
 
  make
 
  make
 
  sudo make install
 
  sudo make install
 +
</strike>
 +
 +
== ODE ==
 +
If your system is x86, just install the APT package: (''This did not work for me. I recommend installing from src.'')
 +
sudo apt-get install libode0debian1
 +
 +
If not, download ODE 0.11 from here http://sourceforge.net/project/showfiles.php?group_id=24884
 +
 +
Compile and install with:
 +
 +
./autogen.sh
 +
./configure --with-trimesh=opcode --prefix=/usr --enable-shared --disable-demos --enable-new-trimesh
 +
make
 +
sudo make install
 +
 +
== OpenAL ==
 +
Nothing complicated.
 +
 +
Under ubuntu 8.04:
 +
  sudo apt-get install libopenal0a
 +
 +
Under Ubuntu 9.04:
 +
  sudo apt-get install libopenal1 libalut0
 +
 +
== TAO Framework ==
 +
Download from here: http://sourceforge.net/project/showfiles.php?group_id=170616
 +
 +
If you installed ODE from the APT repository, you just have nothing to do.
 +
 +
If not, edit ''bin/Tao.Ode.dll.config'', replace
 +
<dllentry os="linux" dll="libode.so.0debian1" />
 +
by
 +
<dllentry os="linux" dll="libode.so" />
 +
 +
== About not polluting the system ==
 +
 +
=== Forewords ===
 +
 +
I like to keep my system clean. Installing all the ''non-packaged'' software into an non-system directory makes the installation process a tiny little more work but allows not to create too much mess. It also allows to make different version of libraries lives together into your system happily.
 +
 +
=== How to ===
 +
 +
Choose your root directory for installing libs, here is mine:
 +
 +
  ROOT=/home/jeko/WIP/openracing/opt
 +
 +
Then, what you'll basically have to do is to specify --prefix=$ROOT to the ./configure commands above. But first we need to help autoconf cmake and others to find libraries in this directory.
 +
 +
I created the following $ROOT/setenv.bash file:
 +
 +
  ROOT=/home/jeko/WIP/openracing/opt
 +
 
 +
  export PKG_CONFIG_PATH=$ROOT/lib/pkgconfig:$PKG_CONFIG_PATH
 +
  export PATH=$ROOT/bin:$PATH
 +
  export LD_LIBRARY_PATH=$ROOT/lib:$LD_LIBRARY_PATH
 +
  export CMAKE_INCLUDE_PATH=$ROOT/include:$CMAKE_INCLUDE_PATH
 +
  export CMAKE_LIBRARY_PATH=$ROOT/lib:$CMAKE_INCLUDE_PATH
 +
 +
Then into the console I use for working on OpenRacing, I execute this:
 +
 +
  . $ROOT/setenv.bash
 +
 +
This have to be done every time you start working on OpenRacing. But if your all life is dedicated to OpenRacing, you can add the above command to your .bashrc file ;-)
 +
 +
Now we're pretty done, just follow the installation process described above, just remember to replace ''--prefix=/usr'' by ''--prefix=$ROOT'', and enjoy your clean OpenRacing configuration!

Latest revision as of 13:31, 26 May 2009

MonoDevelop

Ubuntu 9.04 has Mono 2.0 and MonoDevelop 2.0 beta. All the pieces are now in the repository!

sudo apt-get install monodevelop-debugger-mdb monodevelop-debugger-gdb

OIS

Get OIS 1.2 from sourceforge:

sh bootstrap
./configure --prefix=/usr
make
sudo make install

Ogre3D from source

OgreDotNet complains if you do not have the NVidia Cg Toolkit Ogre plugin installed. It's not compiled in within ubuntu's ogre distribution, that is why we need to install Ogre3D from sources.

Dependencies :

sudo aptitude install libzzip-dev libzzip-0-13 libxaw-headers libxmu-dev \
libxmu-headers libxpm-dev libfreeimage-dev libfreeimage3 libxrandr nvidia-cg-toolkit \
libfreetype6-dev libxaw7-dev libxxf86vm-dev libxrandr-dev xlibmesa-glu liblu1-mesa-dev

Get:

wget http://downloads.sourceforge.net/ogre/ogre-v1-4-9.tar.bz2

Build:

./configure --prefix=/usr --enable-openexr && make && sudo make install

OgreDotNet

sudo aptitude install swig cmake nant libmono-winforms2.0-cil
svn checkout http://ogredotnet.googlecode.com/svn/trunk/ ogredotnet-read-only 
cd ogredotnet-read-only
./build.sh

Issue

Under some circumstances, prebuild complains because the root Xml node of the prebuild.xml file should be called "PreBuild" instead of "Prebuild" (notice the subtle uppercase B). Try both in case of doubt.

MyGUI

sudo aptitude install uuid-dev uuid libfreetype6-dev libfreetype6
bzr branch lp:~jeko-ios-software/openracing/mygui-or
cd mygui-or
./configure --with-ogredotnet=../ogredotnet-read-only/bin
make
sudo make install

Below is not used yet:

svn co https://my-gui.svn.sourceforge.net/svnroot/my-gui/trunk my-gui  
cd my-gui
sh bootstrap
./configure --prefix=/usr
make
sudo make install

ODE

If your system is x86, just install the APT package: (This did not work for me. I recommend installing from src.)

sudo apt-get install libode0debian1

If not, download ODE 0.11 from here http://sourceforge.net/project/showfiles.php?group_id=24884

Compile and install with:

./autogen.sh
./configure --with-trimesh=opcode --prefix=/usr --enable-shared --disable-demos --enable-new-trimesh
make
sudo make install

OpenAL

Nothing complicated.

Under ubuntu 8.04:

 sudo apt-get install libopenal0a

Under Ubuntu 9.04:

 sudo apt-get install libopenal1 libalut0

TAO Framework

Download from here: http://sourceforge.net/project/showfiles.php?group_id=170616

If you installed ODE from the APT repository, you just have nothing to do.

If not, edit bin/Tao.Ode.dll.config, replace

<dllentry os="linux" dll="libode.so.0debian1" />

by

<dllentry os="linux" dll="libode.so" />

About not polluting the system

Forewords

I like to keep my system clean. Installing all the non-packaged software into an non-system directory makes the installation process a tiny little more work but allows not to create too much mess. It also allows to make different version of libraries lives together into your system happily.

How to

Choose your root directory for installing libs, here is mine:

 ROOT=/home/jeko/WIP/openracing/opt

Then, what you'll basically have to do is to specify --prefix=$ROOT to the ./configure commands above. But first we need to help autoconf cmake and others to find libraries in this directory.

I created the following $ROOT/setenv.bash file:

 ROOT=/home/jeko/WIP/openracing/opt
 
 export PKG_CONFIG_PATH=$ROOT/lib/pkgconfig:$PKG_CONFIG_PATH
 export PATH=$ROOT/bin:$PATH
 export LD_LIBRARY_PATH=$ROOT/lib:$LD_LIBRARY_PATH
 export CMAKE_INCLUDE_PATH=$ROOT/include:$CMAKE_INCLUDE_PATH
 export CMAKE_LIBRARY_PATH=$ROOT/lib:$CMAKE_INCLUDE_PATH

Then into the console I use for working on OpenRacing, I execute this:

 . $ROOT/setenv.bash

This have to be done every time you start working on OpenRacing. But if your all life is dedicated to OpenRacing, you can add the above command to your .bashrc file ;-)

Now we're pretty done, just follow the installation process described above, just remember to replace --prefix=/usr by --prefix=$ROOT, and enjoy your clean OpenRacing configuration!