Difference between revisions of "Ubuntu-Linux Users"

From SpaceElevatorWiki.com
Line 1: Line 1:
''Page in progress''
+
== MonoDevelop ==
 +
Ubuntu 9.04 has Mono 2.0 and MonoDevelop 2.0 beta. All the pieces are now in the repository!
 +
 
 +
sudo apt-get install monodevelop-debugger-mdb monodevelop-debugger-gdb
  
 
== OIS ==
 
== OIS ==
 
 
Get OIS 1.2 from sourceforge:
 
Get OIS 1.2 from sourceforge:
  
Line 11: Line 13:
  
 
== Ogre3D from source ==
 
== Ogre3D from source ==
 
 
OgreDotNet complains if you do not have the NVidia Cg Toolkit Ogre plugin installed. It's not compiled in within ubuntu's ogre distribution, that is why we need to install Ogre3D from sources.
 
OgreDotNet complains if you do not have the NVidia Cg Toolkit Ogre plugin installed. It's not compiled in within ubuntu's ogre distribution, that is why we need to install Ogre3D from sources.
  
Line 24: Line 25:
  
 
== OgreDotNet ==
 
== OgreDotNet ==
 
 
  sudo aptitude install swig cmake nant libmono-winforms2.0-cil
 
  sudo aptitude install swig cmake nant libmono-winforms2.0-cil
  
Line 32: Line 32:
  
 
== MyGUI ==
 
== MyGUI ==
 
 
  sudo aptitude install uuid-dev uuid libfreetype6-dev libfreetype6
 
  sudo aptitude install uuid-dev uuid libfreetype6-dev libfreetype6
 
  bzr branch lp:~jeko-ios-software/openracing/mygui-or
 
  bzr branch lp:~jeko-ios-software/openracing/mygui-or

Revision as of 23:09, 20 March 2009

MonoDevelop

Ubuntu 9.04 has Mono 2.0 and MonoDevelop 2.0 beta. All the pieces are now in the repository!

sudo apt-get install monodevelop-debugger-mdb monodevelop-debugger-gdb

OIS

Get OIS 1.2 from sourceforge:

sh bootstrap
./configure --prefix=/usr
make
sudo make install

Ogre3D from source

OgreDotNet complains if you do not have the NVidia Cg Toolkit Ogre plugin installed. It's not compiled in within ubuntu's ogre distribution, that is why we need to install Ogre3D from sources.

Dependencies :

sudo aptitude install libzzip-dev libzzip-0-13 libxaw-headers libxmu-dev \
libxmu-headers libxpm-dev libfreeimage-dev libfreeimage3 libxrandr nvidia-cg-toolkit \
libfreetype6-dev libxaw7-dev libxxf86vm-dev libxrandr-dev xlibmesa-glu liblu1-mesa-dev

Get:

wget http://downloads.sourceforge.net/ogre/ogre-v1-4-9.tar.bz2

Build:

./configure --prefix=/usr --enable-openexr && make && sudo make install

OgreDotNet

sudo aptitude install swig cmake nant libmono-winforms2.0-cil
svn checkout http://ogredotnet.googlecode.com/svn/trunk/ ogredotnet-read-only 
cd ogredotnet-read-only
./build.sh

MyGUI

sudo aptitude install uuid-dev uuid libfreetype6-dev libfreetype6
bzr branch lp:~jeko-ios-software/openracing/mygui-or
cd mygui-or
./configure --with-ogredotnet=../ogredotnet-read-only/bin
make
sudo make install

Below is not used yet:

svn co https://my-gui.svn.sourceforge.net/svnroot/my-gui/trunk my-gui  
cd my-gui
sh bootstrap
./configure --prefix=/usr
make
sudo make install

ODE

(NOT NEEDED FOR TRUNK)

If your system is x86, just install the APT package:

sudo apt-get install libode0debian1

If not, download ODE 0.11 from here http://sourceforge.net/project/showfiles.php?group_id=24884

Compile and install with:

sh autogen.sh
./configure --with-trimesh=opcode --prefix=/usr --enable-shared --disable-demos --enable-new-trimesh
make
sudo make install

TAO Framework

(NOT NEEDED FOR TRUNK)

Download from here: http://sourceforge.net/project/showfiles.php?group_id=170616

If you installed ODE from the APT repository, you just have nothing to do.

If not, edit bin/Tao.Ode.dll.config, replace

<dllentry os="linux" dll="libode.so.0debian1" />

by

<dllentry os="linux" dll="libode.so" />